Campaign Creation

Incident Report for Text Management

Resolved

This incident has been resolved.
Posted Nov 15, 2024 - 09:04 GMT

Update

We are continuing to investigate this issue.
Posted Nov 14, 2024 - 15:53 GMT

Investigating

We are aware of a delay in campaign creation.
Posted Nov 14, 2024 - 15:52 GMT